2011年2月25日金曜日

Debian Lenny Ruby1.9.2でRMagick 2.13.1を入れる

情報源

How do I install ImageMagick 6.5.6 on Debian Lenny?

Debian LennyのRMagickがgem install時に古くて怒られる

しかもpngのリサイズ時にバグがあるんだそうです... じゃあ新しいのを入れてやる!ってことで頑張ってみました

インストール手順

vim /etc/apt/sources.list
deb-src http://http.us.debian.org/debian squeeze main contrib non-free

apt-get update
apt-get build-dep imagemagick
apt-get source imagemagick
cd imagemagick-6.6.0.4
debian/rules binary
cd ..
dpkg -i *.deb

gem install rmagick

0 件のコメント: